intel服務(wù)器網(wǎng)卡 | intel網(wǎng)卡 | intel光纖網(wǎng)卡 
TeL: 020-85205216   
電話(huà):020-85205216
020-85205216
24小時(shí)熱線(xiàn):136 1022 8025
136 1022 8025
傳真:020-22065085 email:179321907@qq.com
網(wǎng)址:www.gz-sowide.com
資訊詳情:

網(wǎng)絡(luò )交換機的三種vlan劃分方法詳解

時(shí)間:2020-11-07 17:49:13  作者:  來(lái)源:瀏覽:人次

網(wǎng)絡(luò )交換機的三種vlan劃分方法詳解

有很多的朋友提到了vlan的劃分,今天我們來(lái)看下具體應用。

很多朋友在留言中也多次提到了華為交換機,華為也是在項目中用的比較多交換機,因此,我們今天以華為交換機為例,來(lái)講解vlan的3種劃分方法,360度來(lái)了解vlan。

如果你以對vlan了解不多,那么這篇文章可以帶你深入學(xué)習vlan,都有詳細注釋。

我們前面曾說(shuō)到,關(guān)于vlan的劃分方法有很多,項目應用中較多的方法就是基于端口劃分vlan、基于mac地址劃分vlan、基于ip地址劃分vlan,要真正對vlan了解,必須熟悉這三次劃分方法,以便于根據實(shí)際項目進(jìn)行應用。

一、基于端口的vlan劃分方法
這里面為了方便大家理解,直接用實(shí)例講解更清楚。
1、組網(wǎng)需求
如圖1所示,某企業(yè)的交換機連接有很多用戶(hù),且相同業(yè)務(wù)用戶(hù)通過(guò)不同的設備接入企業(yè)網(wǎng)絡(luò )。為了通信的安全性,也為了避免廣播報文泛濫,企業(yè)希望業(yè)務(wù)相同用戶(hù)之間可以互相訪(fǎng)問(wèn),業(yè)務(wù)不同用戶(hù)不能直接訪(fǎng)問(wèn)。

可以在交換機上配置基于端口劃分VLAN,把業(yè)務(wù)相同的用戶(hù)連接的端口劃分到同一VLAN。

也就是不同VLAN的用戶(hù)不能直接進(jìn)行二層通信,同一VLAN內的用戶(hù)可以直接互相通信。

2、配置步驟

步驟1:在SwitchA創(chuàng )建VLAN2和VLAN3,并將連接用戶(hù)的端口分別加入VLAN。SwitchB配置與SwitchA類(lèi)似,不再贅述。
[Quidway] system-view          //進(jìn)入配置視圖
[Quidway] sysname SwitchA   //給交換機命名
[SwitchA] vlan batch 2 3          //同時(shí)創(chuàng )建vlan2與vlan3
[SwitchA] interface ethernet 0/0/1   //進(jìn)入端口0/0/1
[SwitchA-Ethernet0/0/1] port link-type access   //設置端口模式為access
[SwitchA-Ethernet0/0/1] port default vlan 2      //將端口加入vlan2中
[SwitchA-Ethernet0/0/1] quit   //退出
[SwitchA] interface ethernet 0/0/2   //進(jìn)入端口0/0/2
[SwitchA-Ethernet0/0/2] port link-type access  //端口模式為access
[SwitchA-Ethernet0/0/2] port default vlan 3    //將端口加入vlan3中
[SwitchA-Ethernet0/0/2] quit   //退出


步驟2 配置SwitchA上與SwitchB連接的端口類(lèi)型及通過(guò)的VLAN。SwitchB配置與SwitchA類(lèi)似,不再贅述。

[SwitchA] interface ethernet 0/0/3 //進(jìn)入端口0/0/3
[SwitchA-Ethernet0/0/3] port link-type trunk   //設置端口模式為trunk
[SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3   //trunk口允許通過(guò)vlan2與vlan3的數據包

步驟3

驗證配置結果將User1和User2配置在一個(gè)網(wǎng)段,比如192.168.100.0/24;將User3和User4配置在一個(gè)網(wǎng)段,比如192.168.200.0/24。

User1和User2能夠互相ping通,但是均不能ping通User3和User4。User3和User4能夠互相ping通,但是均不能ping通User1和User2。

二、基于MAC地址vlan劃分方法
1、組網(wǎng)需求
某個(gè)公司的網(wǎng)絡(luò )中,網(wǎng)絡(luò )管理者將同一部門(mén)的員工劃分到同一VLAN。為了提高部門(mén)內的信息安全,要求只有本部門(mén)員工的PC才可以訪(fǎng)問(wèn)公司網(wǎng)絡(luò )。

如圖2所示,PC1、PC2、PC3為本部門(mén)員工的PC,要求這幾臺PC可以通過(guò)SwitchA、Switch訪(fǎng)問(wèn)公司網(wǎng)絡(luò ),如換成其他PC則不能訪(fǎng)問(wèn)??梢耘渲没贛AC地址劃分VLAN,將本部門(mén)員工PC的MAC地址與VLAN綁定,從而實(shí)現該需求。

2、操作步驟

這里面弱電君對上面重復的注釋就不再解釋了,和上面一樣,大家也可以驗證下,經(jīng)過(guò)上面的理解,是否能認識下面的配置代碼。

步驟1 配置Switch

# 創(chuàng )建VLAN
[Quidway] system-view  
[Quidway] vlan batch 10 100


# 配置接口的PVID和加入VLAN
[Quidway] interface ethernet 0/0/1  
[Quidway-Ethernet0/0/1] port hybrid pvid vlan 100 //將接口以加入到vlan100

[Quidway-Ethernet0/0/1] port hybrid untagged vlan 10   //untagged是指當數據離開(kāi)端口時(shí)脫掉標簽,指定端口允許VLAN 10的數據幀通過(guò),且發(fā)送時(shí)不帶VLAN標簽  
[Quidway-Ethernet0/0/1] quit  #退出

[Quidway] interface ethernet 0/0/2    #進(jìn)入端口0/0/2
[Quidway-Ethernet0/0/2] port hybrid tagged vlan 10 //tagged是指當數據離開(kāi)端口時(shí)帶著(zhù)標簽,指定允許VLAN 10的數據幀通過(guò),且發(fā)送時(shí)必須帶有VLAN標簽  

[Quidway-Ethernet0/0/2] quit


# PC的MAC地址與VLAN10關(guān)聯(lián)
[Quidway] vlan 10
[Quidway-Vlan10] mac-vlan mac-address 22-22-22  
//關(guān)聯(lián)pc1的mac地址
[Quidway-Vlan10] mac-vlan mac-address 33-33-33 

 //關(guān)聯(lián)pc2的mac地址

[Quidway-Vlan10] mac-vlan mac-address 44-44-44   

//關(guān)聯(lián)pc3的mac地址

[Quidway-Vlan10] quit


# 使能接口的基于MAC地址劃分VLAN功能
[Quidway] interface ethernet 0/0/1
[Quidway-Ethernet0/0/1] mac-vlan enable 

 //起動(dòng)端口的mac-vlan功能

[Quidway-Ethernet0/0/1] quit

三、基于IP子網(wǎng)的vlan劃分
1、組網(wǎng)需求

某企業(yè)擁有多種業(yè)務(wù),如IPTV、VoIP、Internet等,每種業(yè)務(wù)使用的IP地址網(wǎng)段各不相同。為了便于管理,現需要將同一種類(lèi)型業(yè)務(wù)劃分到同一VLAN中,不同類(lèi)型的業(yè)務(wù)劃分到不同VLAN中。

如圖3所示,Switch接收到用戶(hù)報文有數據、IPTV、語(yǔ)音等多種業(yè)務(wù),用戶(hù)設備的IP地址網(wǎng)段各不相同?,F需要將不同類(lèi)型的業(yè)務(wù)劃分到不同的VLAN中,通過(guò)不同的VLANID分流到不同的遠端服務(wù)器上以實(shí)現業(yè)務(wù)互通。

這類(lèi)在實(shí)際應用中是比較多的。

2、配置思路

采用如下的思路配置基于IP子網(wǎng)劃分VLAN:

a、創(chuàng )建VLAN,確定每種業(yè)務(wù)所屬的VLAN。
b、關(guān)聯(lián)IP子網(wǎng)和VLAN,實(shí)現根據報文中的源IP地址或指定網(wǎng)段確定VLAN。
c、配置端口加入VLAN,實(shí)現基于IP子網(wǎng)的VLAN通過(guò)當前端口。
d、配置VLAN劃分方式的優(yōu)先級,確保優(yōu)先選擇基于IP子網(wǎng)劃分VLAN。
e、使能基于IP子網(wǎng)劃分VLAN。

3、操作步驟

步驟1 創(chuàng )建VLAN
# 在Switch上創(chuàng )建VLAN100、VLAN200和VLAN300。
[Quidway] system-view
[Quidway] vlan batch 100 200 300


步驟2 配置接口

# 在Switch上配置接口Eth0/0/1為Hybrid類(lèi)型,并加入VLAN100、VLAN200和VLAN300。

[Quidway] interface ethernet 0/0/1
[Quidway-Ethernet0/0/1] port link-type hybrid    //設置端口為hybrid模式

[Quidway-Ethernet0/0/1] port hybrid untagged vlan100 200 300   //指定端口允許VLAN 100、vlan200、vlan300的數據幀通過(guò),且發(fā)送時(shí)不帶VLAN標簽  

[Quidway-Ethernet0/0/1] quit

# 在Switch上配置接口Eth0/0/2加入VLAN100。

[Quidway] interface ethernet 0/0/2
[Quidway-Ethernet0/0/2] port link-type trunk
[Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100    //接口0/0/2加入vlan100

[Quidway-Ethernet0/0/2] quit

# 在Switch上配置接口Eth0/0/3加入VLAN200。
[Quidway] interface ethernet 0/0/3
[Quidway-Ethernet0/0/3] port link-type trunk
[Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200  //接口0/0/3加入vlan200

[Quidway-Ethernet0/0/3] quit


# 在Switch上配置接口Eth0/0/4加入VLAN300。
[Quidway] interface ethernet 0/0/4
[Quidway-Ethernet0/0/4] port link-type trunk
[Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300  //接口0/0/4加入vlan300

[Quidway-Ethernet0/0/4] quit


# 在Switch上配置接口Eth0/0/1使能基于IP子網(wǎng)劃分VLAN功能。
[Quidway] interface ethernet 0/0/1
[Quidway-Ethernet0/0/1] ip-subnet-vlan enable
[Quidway-Ethernet0/0/1] quit


步驟3 配置基于IP子網(wǎng)劃分VLAN

# 在Switch上配置VLAN100與IP地址192.168.1.2/24關(guān)聯(lián),優(yōu)先級為2。

[Quidway] vlan 100
[Quidway-vlan100] ip-subnet-vlan 100 ip 192.168.1.2 24 priority 2
[Quidway-vlan100] quit

# 在Switch上配置VLAN200與IP地址192.168.2.2/24關(guān)聯(lián),優(yōu)先級為3。
[Quidway] vlan 200
[Quidway-vlan200] ip-subnet-vlan 200 ip 192.168.2.2 24 priority 3
[Quidway-vlan200] quit

# 在Switch上配置VLAN300與IP地址192.168.3.2/24關(guān)聯(lián),優(yōu)先級為4。
[Quidway] vlan 300
[Quidway-vlan300] ip-subnet-vlan 300 ip 192.168.3.2 24 priority 4
[Quidway-vlan300] quit


步驟4 驗證配置結果

在Switch上執行以下命令,顯示信息如下:
[Quidway] display ip-subnet-vlan vlan all
----------------------------------------------------------------
Vlan Index IpAddress SubnetMask Priority
----------------------------------------------------------------
100 1 192.168.1.2 255.255.255.0 2
200 1 192.168.2.2 255.255.255.0 3
300 1 192.168.3.2 255.255.255.0 4
----------------------------------------------------------------
ip-subnet-vlan count: 3 total count: 3

即為組網(wǎng)配置成功。

網(wǎng)站首頁(yè)| 公司簡(jiǎn)介| 資訊中心| 產(chǎn)品展示| 工程案例| 招商加盟| 聯(lián)系我們

廣州吉悅計算機科技有限公司© 2005 - 2010 All Rights Reserved.
公司地址:廣州市天河區石牌西路8號展望數碼廣場(chǎng)850A  聯(lián)系電話(huà)020-85205216 Email:179321907@qq.com
網(wǎng)站備案號:粵ICP備19142146號    Powered by 【廣州吉悅計算機科技有限公司】